JUnit 5.1.0  - 改进对 Java 9 模块化和 Kotlin 的支持

JUnit 5.1.0 - 改进对 Java 9 模块化和 Kotlin 的支持

🗨

JUnit 5.1.0 已发布,主要更新内容包括:

  • Java 9 模块化 Discovering 测试

  • 改进 Kotlin 支持

  • 通过 @RegisterExtension 扩展编程方式配置

  • 标记表达式语言,以过滤要执行的测试

  • 改进参数化测试编写

  • 改进 ExtensionContext API

  • 支持在 IDE 中重新运行单个动态测试、参数化测试和测试模板调用

完整更新内容请查阅:

需注意的是,JUnit 5.0 更新后对 Java 运行环境的最低要求是 Java 8。


频道:Java
扫描本文章二维码可手机访问: